Computer Guts LLC - Status - TEMPORARY NETWORK ISSUES WITH EMAIL DELIVERABILITY ON VPS and DEDICATED SERVERS – Incident details

All systems operational

TEMPORARY NETWORK ISSUES WITH EMAIL DELIVERABILITY ON VPS and DEDICATED SERVERS

Resolved
Major outage
Started 29 days agoLasted about 5 hours

Affected

Email

Degraded performance from 2:30 PM to 7:27 PM

Basic Email Service

Degraded performance from 2:30 PM to 7:27 PM

Updates
  • Resolved
    Resolved
    Sent emails were being rejected as SPAM or sending too many emails. This incident has been resolved.
  • Investigating
    Investigating
    Sent emails are being rejected as SPAM or sending too many emails.